const regex = new RegExp('Let\\'s start(.*[\\r\\n])*.*my friend\\.', 'gm')
const str = `How much wood? Who knew! Let's start! ... blah, blah, blah...
How much
longer? It's joe's place*, isn't it?
This is! [the end], my friend. Ok, Let's do some more testing.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}