using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(filter: {[^}]*})(.*)";
string input = @"# input
query: ""\n mutation deepCopyIxWithKm($creator: String!, $sourceTenant: String!, $targetTenant: String!, $assetId: String!, $deepCopyKm: Boolean!) {\n deepCopyIx(\n creator: $creator\n targetTenantId: $targetTenant\n assetId: $assetId\n sourceTenantId: $sourceTenant\n isDeepCopyKM: $deepCopyKm\n ) {\n ix {\n id\n }\n }\n}\n ""
# expected output
{""query"":""query OpName { itemCollection (filter: { text: ""aa aa aa"", text2: ""aa aa""}){ group { slug text text2 } } }""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}