const regex = /(.*?)(filter: {[^}]*})(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)(filter: {[^}]*})(.*)', 'gm')
const str = `# input
query: "\\n mutation deepCopyIxWithKm(\$creator: String!, \$sourceTenant: String!, \$targetTenant: String!, \$assetId: String!, \$deepCopyKm: Boolean!) {\\n deepCopyIx(\\n creator: \$creator\\n targetTenantId: \$targetTenant\\n assetId: \$assetId\\n sourceTenantId: \$sourceTenant\\n isDeepCopyKM: \$deepCopyKm\\n ) {\\n ix {\\n id\\n }\\n }\\n}\\n "
# expected output
{"query":"query OpName { itemCollection (filter: { text: "aa aa aa", text2: "aa aa"}){ group { slug text text2 } } }"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}