re = /(.*?)(filter: {[^}]*})(.*)/m
str = '# input
query: "\\n mutation deepCopyIxWithKm($creator: String!, $sourceTenant: String!, $targetTenant: String!, $assetId: String!, $deepCopyKm: Boolean!) {\\n deepCopyIx(\\n creator: $creator\\n targetTenantId: $targetTenant\\n assetId: $assetId\\n sourceTenantId: $sourceTenant\\n isDeepCopyKM: $deepCopyKm\\n ) {\\n ix {\\n id\\n }\\n }\\n}\\n "
# expected output
{"query":"query OpName { itemCollection (filter: { text: "aa aa aa", text2: "aa aa"}){ group { slug text text2 } } }"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end