import re
regex = re.compile(r"(.*?)(filter: {[^}]*})(.*)", flags=re.MULTILINE)
test_str = ("# input\n"
"query: \"\\n mutation deepCopyIxWithKm($creator: String!, $sourceTenant: String!, $targetTenant: String!, $assetId: String!, $deepCopyKm: Boolean!) {\\n deepCopyIx(\\n creator: $creator\\n targetTenantId: $targetTenant\\n assetId: $assetId\\n sourceTenantId: $sourceTenant\\n isDeepCopyKM: $deepCopyKm\\n ) {\\n ix {\\n id\\n }\\n }\\n}\\n \"\n\n"
"# expected output\n"
"{\"query\":\"query OpName { itemCollection (filter: { text: \"aa aa aa\", text2: \"aa aa\"}){ group { slug text text2 } } }\"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")