import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<a>)(\\s*?<b>([^<]+)<\\/b>)(\\s*?<b>([^<]+)<\\/b>)?(\\s*?<b>([^<]+)<\\/b>)?(\\s*?<b>([^<]+)<\\/b>)?";
final String string = "<a>\n"
+ "<b>test11</b>\n"
+ "</a>\n\n"
+ "<a>\n"
+ "<b>test21</b>\n"
+ "<b>test22</b>\n"
+ "</a>\n\n"
+ "<a>\n"
+ "<b>test31</b>\n"
+ "<b>test32</b>\n"
+ "<b>test33</b>\n"
+ "</a>\n\n"
+ "<a>\n"
+ "<b>test41</b>\n"
+ "<b>test42</b>\n"
+ "<b>test43</b>\n"
+ "<b>test44</b>\n"
+ "</a>\n\n"
+ "<c>\n"
+ "<b>test51</b>\n"
+ "<b>test52</b>\n"
+ "</c>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}