$re = '/(?<=<a>)(\s*?<b>([^<]+)<\/b>)(\s*?<b>([^<]+)<\/b>)?(\s*?<b>([^<]+)<\/b>)?(\s*?<b>([^<]+)<\/b>)?/m';
$str = '<a>
<b>test11</b>
</a>
<a>
<b>test21</b>
<b>test22</b>
</a>
<a>
<b>test31</b>
<b>test32</b>
<b>test33</b>
</a>
<a>
<b>test41</b>
<b>test42</b>
<b>test43</b>
<b>test44</b>
</a>
<c>
<b>test51</b>
<b>test52</b>
</c>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);