import re
regex = re.compile(r"(?<=<a>)(\s*?<b>([^<]+)<\/b>)(\s*?<b>([^<]+)<\/b>)?(\s*?<b>([^<]+)<\/b>)?(\s*?<b>([^<]+)<\/b>)?", flags=re.MULTILINE)
test_str = ("<a>\n"
"<b>test11</b>\n"
"</a>\n\n"
"<a>\n"
"<b>test21</b>\n"
"<b>test22</b>\n"
"</a>\n\n"
"<a>\n"
"<b>test31</b>\n"
"<b>test32</b>\n"
"<b>test33</b>\n"
"</a>\n\n"
"<a>\n"
"<b>test41</b>\n"
"<b>test42</b>\n"
"<b>test43</b>\n"
"<b>test44</b>\n"
"</a>\n\n"
"<c>\n"
"<b>test51</b>\n"
"<b>test52</b>\n"
"</c>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")