package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d+).(\d+).(\d+).(\d+)\b`)
var str = `192.168.1.1
Localhost 127.0.0.1
Mask 255.255.255.255
My local IP 192.168.0.110
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}