const regex = /\b(\d+).(\d+).(\d+).(\d+)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+).(\\d+).(\\d+).(\\d+)\\b', 'gm')
const str = `192.168.1.1
Localhost 127.0.0.1
Mask 255.255.255.255
My local IP 192.168.0.110
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}