import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d+).(\\d+).(\\d+).(\\d+)\\b";
final String string = "192.168.1.1\n"
+ "Localhost 127.0.0.1\n"
+ "Mask 255.255.255.255\n"
+ "My local IP 192.168.0.110\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}