re = /\b(\d+).(\d+).(\d+).(\d+)\b/m
str = '192.168.1.1
Localhost 127.0.0.1
Mask 255.255.255.255
My local IP 192.168.0.110
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end