#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(bi-.[a-zA-Z\-]*)"
Local $sString = "bi bi-envelope-fill text-red me-2 flex-shrink-0" & @CRLF & _
"bi bi-envelope-fill" & @CRLF & _
"bi-envelope-fill text-red me-2 flex-shrink-0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")