re = /(bi-.[a-zA-Z\-]*)/m
str = 'bi bi-envelope-fill text-red me-2 flex-shrink-0
bi bi-envelope-fill
bi-envelope-fill text-red me-2 flex-shrink-0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end