package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(bi-.[a-zA-Z\-]*)`)
var str = `bi bi-envelope-fill text-red me-2 flex-shrink-0
bi bi-envelope-fill
bi-envelope-fill text-red me-2 flex-shrink-0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}