import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(bi-.[a-zA-Z\\-]*)";
final String string = "bi bi-envelope-fill text-red me-2 flex-shrink-0\n"
+ "bi bi-envelope-fill\n"
+ "bi-envelope-fill text-red me-2 flex-shrink-0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}