using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([^\s<>]{2,}[^\s\.<>](\.|:\/\/)[^\s\.<>][^\s<>]+)\b";
string input = @"sgsdg://sdfsdfg fgsg.sdgsg sgsdgs:sdgsdg 21.5c ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}