package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([^\s<>]{2,}[^\s\.<>](\.|:\/\/)[^\s\.<>][^\s<>]+)\b`)
var str = `sgsdg://sdfsdfg fgsg.sdgsg sgsdgs:sdgsdg 21.5c `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}