re = /\b([^\s<>]{2,}[^\s\.<>](\.|:\/\/)[^\s\.<>][^\s<>]+)\b/m
str = 'sgsdg://sdfsdfg fgsg.sdgsg sgsdgs:sdgsdg 21.5c '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end