const regex = /^\s+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s+\\b', 'gm')
const str = `IF THIS IS THE CODE
AND THIS IS THE NEXT LINE
AND THIS IS THE THIRD LINE`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);