$re = '/^\s+\b/m';
$str = 'IF THIS IS THE CODE
AND THIS IS THE NEXT LINE
AND THIS IS THE THIRD LINE';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;