re = /^\s+\b/m
str = 'IF THIS IS THE CODE
AND THIS IS THE NEXT LINE
AND THIS IS THE THIRD LINE'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result