import re
regex = re.compile(r"^\s+\b", flags=re.MULTILINE)
test_str = ("IF THIS IS THE CODE\n"
" AND THIS IS THE NEXT LINE\n"
" AND THIS IS THE THIRD LINE")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)