using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]{4,5}(;[0-9]{4,5})*$";
string input = @"1111;11111;11111;1111;11111
111;11111;111111111
11111;11111;11111
111
abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}