// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]{4,5}(;[0-9]{4,5})*$").unwrap();
let string = "1111;11111;11111;1111;11111
111;11111;111111111
11111;11111;11111
111
abc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}