re = /^[0-9]{4,5}(;[0-9]{4,5})*$/m
str = '1111;11111;11111;1111;11111
111;11111;111111111
11111;11111;11111
111
abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end