import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<a(?=\\s)(?=(?:[^>\"']|\"[^\"]*\"|'[^']*')*?\\shref\\s*=\\s*(?:(['\"])(?:(?!\\1)[\\S\\s])*?(?:www\\.test\\.com|test\\.com)(?:(?!\\1)[\\S\\s])*?\\1))\\s+(?:\"[\\S\\s]*?\"|'[\\S\\s]*?'|[^>]*?)+>.*?<\\/a\\s*>(*SKIP)(*FAIL)|<a(?=\\s)(?=(?:[^>\"']|\"[^\"]*\"|'[^']*')*?\\shref\\s*=\\s*(?:(['\"])([\\S\\s]*?)\\2))\\s+(?:\"[\\S\\s]*?\"|'[\\S\\s]*?'|[^>]*?)+>(.*?)<\\/a\\s*>)";
final String string = "<a href='https://www.google.lk/' id='21'>Google</a> <a>Solution</a>\n\n\n"
+ "<a href='https://www.test.com/lk/' id='21'>Google</a><a href='https://www.google.lk/' id='21'>Google</a> <a>Solution</a>\n\n"
+ "<a href='https://www.google.lk/' id='21'>Google</a> <a>Solution</a>\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}