const regex = /(?:<a(?=\s)(?=(?:[^>"']|"[^"]*"|'[^']*')*?\shref\s*=\s*(?:(['"])(?:(?!\1)[\S\s])*?(?:www\.test\.com|test\.com)(?:(?!\1)[\S\s])*?\1))\s+(?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+>.*?<\/a\s*>(*SKIP)(*FAIL)|<a(?=\s)(?=(?:[^>"']|"[^"]*"|'[^']*')*?\shref\s*=\s*(?:(['"])([\S\s]*?)\2))\s+(?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+>(.*?)<\/a\s*>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<a(?=\\s)(?=(?:[^>"\']|"[^"]*"|\'[^\']*\')*?\\shref\\s*=\\s*(?:([\'"])(?:(?!\\1)[\\S\\s])*?(?:www\\.test\\.com|test\\.com)(?:(?!\\1)[\\S\\s])*?\\1))\\s+(?:"[\\S\\s]*?"|\'[\\S\\s]*?\'|[^>]*?)+>.*?<\\\/a\\s*>(*SKIP)(*FAIL)|<a(?=\\s)(?=(?:[^>"\']|"[^"]*"|\'[^\']*\')*?\\shref\\s*=\\s*(?:([\'"])([\\S\\s]*?)\\2))\\s+(?:"[\\S\\s]*?"|\'[\\S\\s]*?\'|[^>]*?)+>(.*?)<\\\/a\\s*>)', 'g')
const str = `<a href='https://www.google.lk/' id='21'>Google</a> <a>Solution</a>
<a href='https://www.test.com/lk/' id='21'>Google</a><a href='https://www.google.lk/' id='21'>Google</a> <a>Solution</a>
<a href='https://www.google.lk/' id='21'>Google</a> <a>Solution</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}