$re = '/(?:<a(?=\s)(?=(?:[^>"\']|"[^"]*"|\'[^\']*\')*?\shref\s*=\s*(?:([\'"])(?:(?!\1)[\S\s])*?(?:www\.test\.com|test\.com)(?:(?!\1)[\S\s])*?\1))\s+(?:"[\S\s]*?"|\'[\S\s]*?\'|[^>]*?)+>.*?<\/a\s*>(*SKIP)(*FAIL)|<a(?=\s)(?=(?:[^>"\']|"[^"]*"|\'[^\']*\')*?\shref\s*=\s*(?:([\'"])([\S\s]*?)\2))\s+(?:"[\S\s]*?"|\'[\S\s]*?\'|[^>]*?)+>(.*?)<\/a\s*>)/';
$str = '<a href=\'https://www.google.lk/\' id=\'21\'>Google</a> <a>Solution</a>
<a href=\'https://www.test.com/lk/\' id=\'21\'>Google</a><a href=\'https://www.google.lk/\' id=\'21\'>Google</a> <a>Solution</a>
<a href=\'https://www.google.lk/\' id=\'21\'>Google</a> <a>Solution</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);