# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<a(?=\s)(?=(?:[^>\"']|\"[^\"]*\"|'[^']*')*?\shref\s*=\s*(?:(['\"])(?:(?!\1)[\S\s])*?(?:www\.test\.com|test\.com)(?:(?!\1)[\S\s])*?\1))\s+(?:\"[\S\s]*?\"|'[\S\s]*?'|[^>]*?)+>.*?<\/a\s*>(*SKIP)(*FAIL)|<a(?=\s)(?=(?:[^>\"']|\"[^\"]*\"|'[^']*')*?\shref\s*=\s*(?:(['\"])([\S\s]*?)\2))\s+(?:\"[\S\s]*?\"|'[\S\s]*?'|[^>]*?)+>(.*?)<\/a\s*>)"
test_str = ("<a href='https://www.google.lk/' id='21'>Google</a> <a>Solution</a>\n\n\n"
"<a href='https://www.test.com/lk/' id='21'>Google</a><a href='https://www.google.lk/' id='21'>Google</a> <a>Solution</a>\n\n"
"<a href='https://www.google.lk/' id='21'>Google</a> <a>Solution</a>\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.