package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(management consultings?|managements?|consultings?)`)
var str = `I have this phrase: "management consulting, infrastructure & government services"
This line has managerial consulate instead.
Here is what the function generated with inputs of ["management","management consulting"]
Here is for inputs of ["management consulting","management"]
This is for consulting for the management`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}