re = /(management consultings?|managements?|consultings?)/m
str = 'I have this phrase: "management consulting, infrastructure & government services"
This line has managerial consulate instead.
Here is what the function generated with inputs of ["management","management consulting"]
Here is for inputs of ["management consulting","management"]
This is for consulting for the management'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end