import re
regex = re.compile(r"(management consultings?|managements?|consultings?)", flags=re.MULTILINE)
test_str = ("I have this phrase: \"management consulting, infrastructure & government services\"\n"
"This line has managerial consulate instead.\n"
"Here is what the function generated with inputs of [\"management\",\"management consulting\"]\n"
"Here is for inputs of [\"management consulting\",\"management\"]\n"
"This is for consulting for the management")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")