$re = '/(management consultings?|managements?|consultings?)/m';
$str = 'I have this phrase: "management consulting, infrastructure & government services"
This line has managerial consulate instead.
Here is what the function generated with inputs of ["management","management consulting"]
Here is for inputs of ["management consulting","management"]
This is for consulting for the management';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);