import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[a-z])(=+)(?!\\s)";
final String string = "<DT><H3 ADD_DATE=\"1727566144\" LAST_MODIFIED=\"1727566144\">produksjonsunderlag=production basis=()(أساس الإنتاج )</H3> \n\n"
+ "<DT><H3 ADD_DATE=\"1727566144\" LAST_MODIFIED=\"1727566144\">produksjonsunderlag|production basis|()(أساس الإنتاج )</H3> \n\n"
+ "<DT><H3 ADD_DATE=\"1727566144\" LAST_MODIFIED=\"1727566144\">antitrust==(مكافحة الاحتكار)</H3>\n"
+ "<DL><p> \n\n"
+ "<DT><H3 ADD_DATE=\"1727566144\" LAST_MODIFIED=\"1727566144\">**antitrust|(مكافحة الاحتكار)**</H3>\n"
+ "<DL><p> ";
final String subst = "|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}