re = /(?<=[a-z])(=+)(?!\s)/m
str = '<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">produksjonsunderlag=production basis=()(أساس الإنتاج )</H3>
<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">produksjonsunderlag|production basis|()(أساس الإنتاج )</H3>
<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">antitrust==(مكافحة الاحتكار)</H3>
<DL><p>
<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">**antitrust|(مكافحة الاحتكار)**</H3>
<DL><p> '
subst = '|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result