#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\[(No|S1|S2|S2 Act 1|S2 Act 2|S2 Act 3|Lore) Spoilers\])?[^\[\]\n]+$"
Local $sString = "[No Spoilers] Here's The Title" & @CRLF & _
"[S2 Act 2 Spoilers] Here's The Title" & @CRLF & _
"Here's The Title" & @CRLF & _
"Here's The Title [No Spoilers]" & @CRLF & _
"[Invalid Spoilers] Here's The Title"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")