const regex = /^(\[(No|S1|S2|S2 Act 1|S2 Act 2|S2 Act 3|Lore) Spoilers\])?[^\[\]\n]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\[(No|S1|S2|S2 Act 1|S2 Act 2|S2 Act 3|Lore) Spoilers\\])?[^\\[\\]\\n]+$', 'gm')
const str = `[No Spoilers] Here's The Title
[S2 Act 2 Spoilers] Here's The Title
Here's The Title
Here's The Title [No Spoilers]
[Invalid Spoilers] Here's The Title`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}