import Foundation
let pattern = #"^(\[(No|S1|S2|S2 Act 1|S2 Act 2|S2 Act 3|Lore) Spoilers\])?[^\[\]\n]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[No Spoilers] Here's The Title
[S2 Act 2 Spoilers] Here's The Title
Here's The Title
Here's The Title [No Spoilers]
[Invalid Spoilers] Here's The Title
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)