$re = '/^(\[(No|S1|S2|S2 Act 1|S2 Act 2|S2 Act 3|Lore) Spoilers\])?[^\[\]\n]+$/m';
$str = '[No Spoilers] Here\'s The Title
[S2 Act 2 Spoilers] Here\'s The Title
Here\'s The Title
Here\'s The Title [No Spoilers]
[Invalid Spoilers] Here\'s The Title';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);