using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(basedir[ ]*=[ ]*"")(.)(:[\/\\])([a-zA-Z0-9]*)([\/\\]?.*)$";
string substitution = @"$1Z$3Here$5";
string input = @"[mysqld]
#skip-innodb
# The TCP/IP Port the MySQL Server will listen on
port=3306
max_allowed_packet=16M
#Path to installation directory. All paths are usually resolved relative to this.
#basedir=""C:/Program Files/MySQL/MySQL Server 5.1/""
basedir=""C:/MySQL/""
#Path to the database root
#datadir=""C:/Documents and Settings/All Users/Application Data/MySQL/MySQL Server 5.1/Data/""
datadir=""C:/MySQLData/""
# The default character set that will be used when a new schema or table is
# created and no character set is defined
default-character-set=utf8";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}