use strict;
my $str = '[mysqld]
#skip-innodb
# The TCP/IP Port the MySQL Server will listen on
port=3306
max_allowed_packet=16M
#Path to installation directory. All paths are usually resolved relative to this.
#basedir="C:/Program Files/MySQL/MySQL Server 5.1/"
basedir="C:/MySQL/"
#Path to the database root
#datadir="C:/Documents and Settings/All Users/Application Data/MySQL/MySQL Server 5.1/Data/"
datadir="C:/MySQLData/"
# The default character set that will be used when a new schema or table is
# created and no character set is defined
default-character-set=utf8';
my $regex = qr/^(basedir[ ]*=[ ]*")(.)(:[\/\\])([a-zA-Z0-9]*)([\/\\]?.*)$/mp;
my $subst = '$1Z$3Here$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";