# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(basedir[ ]*=[ ]*\")(.)(:[\/\\])([a-zA-Z0-9]*)([\/\\]?.*)$"
test_str = ("[mysqld]\n"
"#skip-innodb\n\n"
"# The TCP/IP Port the MySQL Server will listen on\n"
"port=3306\n"
"max_allowed_packet=16M\n\n\n"
"#Path to installation directory. All paths are usually resolved relative to this.\n"
"#basedir=\"C:/Program Files/MySQL/MySQL Server 5.1/\"\n"
"basedir=\"C:/MySQL/\"\n\n"
"#Path to the database root\n"
"#datadir=\"C:/Documents and Settings/All Users/Application Data/MySQL/MySQL Server 5.1/Data/\"\n"
"datadir=\"C:/MySQLData/\"\n\n"
"# The default character set that will be used when a new schema or table is\n"
"# created and no character set is defined\n"
"default-character-set=utf8")
subst = "$1Z$3Here$5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.