#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "@\[(\d+):(\S+)\h+(\S+)\h*\]"
Local $sString = "Hi @[4232:mark__MΛRK ATTLEY] how are you ? " & @CRLF & _
" Hi @[4232:ryan__RYΛN вυηту] how are you ? " & @CRLF & _
" Hi @[4232:david__DΛVID शाहिद ] how are you ?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")