import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@\\[(\\d+):(\\S+)\\h+(\\S+)\\h*\\]";
final String string = "Hi @[4232:mark__MΛRK ATTLEY] how are you ? \n"
+ " Hi @[4232:ryan__RYΛN вυηту] how are you ? \n"
+ " Hi @[4232:david__DΛVID शाहिद ] how are you ?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}