import re
regex = re.compile(r"@\[(\d+):(\S+)\h+(\S+)\h*\]")
test_str = ("Hi @[4232:mark__MΛRK ATTLEY] how are you ? \n"
" Hi @[4232:ryan__RYΛN вυηту] how are you ? \n"
" Hi @[4232:david__DΛVID शाहिद ] how are you ?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")