re = /@\[(\d+):(\S+)\h+(\S+)\h*\]/
str = 'Hi @[4232:mark__MΛRK ATTLEY] how are you ?
Hi @[4232:ryan__RYΛN вυηту] how are you ?
Hi @[4232:david__DΛVID शाहिद ] how are you ?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end