using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w)(\w+(?:-\w+)*)";
string input = @"lower case name
jean-marie
jean-marie-jean
tEST TEST-TEST-tesT";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}