re = /(\w)(\w+(?:-\w+)*)/
str = 'lower case name
jean-marie
jean-marie-jean
tEST TEST-TEST-tesT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end