package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w)(\w+(?:-\w+)*)`)
var str = `lower case name
jean-marie
jean-marie-jean
tEST TEST-TEST-tesT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}